DoS-kwetsbaarheid van WordPress Backup Plugin treft +200.000 sites

Daniel Zijlstra


Een populaire WordPress-back-upplug-in die op meer dan 200.000 websites is geïnstalleerd, heeft onlangs een zeer ernstige kwetsbaarheid gepatcht die tot een denial-of-service-aanval zou kunnen leiden. Wordfence heeft een CVSS-ernstniveau van Hoog toegekend, met een score van 7,5/10, wat aangeeft dat plug-ingebruikers er rekening mee moeten houden en hun plug-in moeten bijwerken.

Back-up plug-in

Het beveiligingslek treft de Backuply WordPress back-upplug-in. Het maken van back-ups is een noodzakelijke functie voor elke website, niet alleen voor WordPress-sites, omdat back-ups uitgevers helpen terug te keren naar een vorige versie als de server defect raakt en gegevens verloren gaan bij een catastrofale storing.

Websiteback-ups zijn van onschatbare waarde bij sitemigraties, herstel na hacking en mislukte updates waardoor een website niet meer functioneert.

Backuply is een bijzonder nuttige plug-in omdat het een back-up maakt van gegevens naar meerdere vertrouwde cloudservices van derden en meerdere manieren ondersteunt om lokale kopieën te downloaden om redundante back-ups te maken, zodat als een cloudback-up slecht is, de site kan worden hersteld vanaf een andere back-up die lokaal is opgeslagen.

Volgens Back-up:

“Backuply wordt geleverd met lokale back-ups en veilige cloudback-ups met eenvoudige integraties met FTP, FTPS, SFTP, WebDAV, Google Drive, Microsoft OneDrive, Dropbox, Amazon S3 en eenvoudig herstel met één klik.”

Kwetsbaarheid die back-up beïnvloedt

De nationale kwetsbaarheidsdatabase van de Amerikaanse overheid waarschuwt dat Backuply tot en met versie 1.2.5 een fout bevat die tot denial of service-aanvallen kan leiden.

De waarschuwing legt uit:

“Dit komt door directe toegang tot het backuply/restore_ins.php-bestand en. Dit maakt het voor niet-geverifieerde aanvallers mogelijk om buitensporige verzoeken te doen die ertoe leiden dat de server geen bronnen meer heeft.”

Denial of Service (DoS)-aanval

Een Denial of Service (DoS)-aanval is een aanval waarbij een fout in de software een aanvaller in staat stelt zoveel snelle verzoeken te doen dat de server geen bronnen meer heeft en geen verdere verzoeken meer kan verwerken, inclusief het aanbieden van webpagina’s aan bezoekers van de site.

Kenmerkend voor DoS-aanvallen is dat het soms mogelijk is scripts, HTML of andere code te uploaden die vervolgens kan worden uitgevoerd, waardoor de aanvaller vrijwel elke actie kan uitvoeren.

Kwetsbaarheden die DoS-aanvallen mogelijk maken, worden als cruciaal beschouwd en er moeten zo snel mogelijk stappen worden ondernomen om deze te beperken.

Back-up Changelog-documentatie

De officiële Backuply changelog, die de details van elke update aankondigt, vermeldt dat er een oplossing is geïmplementeerd in versie 1.2.6. De transparantie en snelle reactie van Backuply zijn verantwoord en een teken van een betrouwbare ontwikkelaar.

Volgens de Wijzigingslog:

“1.2.6 (08 FEBRUARI 2024)
(Security-Fix) In sommige gevallen was het mogelijk om de logboeken te vullen en dit is opgelost. Gerapporteerd door Villu Orav (WordFence)”

Aanbevelingen

Over het algemeen wordt het ten zeerste aanbevolen dat alle gebruikers van de Backuply-plug-in hun plug-in zo snel mogelijk updaten om een ​​ongewenste beveiligingsgebeurtenis te voorkomen.

Lees de beschrijving van de kwetsbaarheid in de National Vulnrability Database:

CVE-2024-0842

Lees het kwetsbaarheidsrapport van Wordfence Backuply:

Back-up – Back-up maken, herstellen, migreren en klonen <= 1.2.5 – Denial of Service

Uitgelichte afbeelding door Shutterstock/Doppelganger4



Source link

Lees ook deze artikelen

Leave a Comment